zookeeper connection loss on table copy

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

zookeeper connection loss on table copy

Shaun Elliott
We're trying to use the built in table copy command to copy from one cluster to another:

hbase org.apache.hadoop.hbase.mapreduce.CopyTable --peer.adr=host1,host2,host3:2181:/hbase TableName

But we're getting the following error:
2015-01-21 17:10:01,017 ERROR org.apache.hadoop.hbase.zookeeper.ZooKeeperWatcher: hconnection Received unexpected KeeperException, re-throwing exception
org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /hbase/hbaseid
        at org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
        at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
        at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:1041)
        at org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.exists(RecoverableZooKeeper.java:172)
        at org.apache.hadoop.hbase.zookeeper.ZKUtil.checkExists(ZKUtil.java:450)
        at org.apache.hadoop.hbase.zookeeper.ClusterId.readClusterIdZNode(ClusterId.java:61)
        at org.apache.hadoop.hbase.zookeeper.ClusterId.getId(ClusterId.java:50)
        at org.apache.hadoop.hbase.zookeeper.ClusterId.hasId(ClusterId.java:44)

Zookeeper and HBase are running fine on both clusters. Is there something else missing here?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Shaun Elliott
It is also throwing this:

2015-01-21 17:10:02,118 INFO org.apache.zookeeper.ClientCnxn: Opening socket connection to server localhost.localdomain/127.0.0.1:2181. Will not attempt to authenticate using SASL (unknown error)
2015-01-21 17:10:02,119 WARN org.apache.zookeeper.ClientCnxn: Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect
java.net.ConnectException: Connection refused
        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
        at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:735)
        at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
        at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1075)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Ted Yu-3
In reply to this post by Shaun Elliott
The znode listed below is hbaseid.

Is that correct ?

Cheers



> On Jan 21, 2015, at 5:32 PM, Shaun Elliott <[hidden email]> wrote:
>
> We're trying to use the built in table copy command to copy from one cluster
> to another:
>
> hbase org.apache.hadoop.hbase.mapreduce.CopyTable
> --peer.adr=host1,host2,host3:2181:/hbase TableName
>
> But we're getting the following error:
> 2015-01-21 17:10:01,017 ERROR
> org.apache.hadoop.hbase.zookeeper.ZooKeeperWatcher: hconnection Received
> unexpected KeeperException, re-throwing exception
> org.apache.zookeeper.KeeperException$ConnectionLossException:
> KeeperErrorCode = ConnectionLoss for /hbase/hbaseid
>    at org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
>    at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
>    at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:1041)
>    at
> org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.exists(RecoverableZooKeeper.java:172)
>    at org.apache.hadoop.hbase.zookeeper.ZKUtil.checkExists(ZKUtil.java:450)
>    at
> org.apache.hadoop.hbase.zookeeper.ClusterId.readClusterIdZNode(ClusterId.java:61)
>    at org.apache.hadoop.hbase.zookeeper.ClusterId.getId(ClusterId.java:50)
>    at org.apache.hadoop.hbase.zookeeper.ClusterId.hasId(ClusterId.java:44)
>
> Zookeeper and HBase are running fine on both clusters. Is there something
> else missing here?
>
>
>
> --
> View this message in context: http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774.html
> Sent from the HBase User mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

stack-3
In reply to this post by Shaun Elliott
zk is listening on port 2181?
St.Ack

On Wed, Jan 21, 2015 at 5:33 PM, Shaun Elliott <[hidden email]>
wrote:

> It is also throwing this:
>
> 2015-01-21 17:10:02,118 INFO org.apache.zookeeper.ClientCnxn: Opening
> socket
> connection to server localhost.localdomain/127.0.0.1:2181. Will not
> attempt
> to authenticate using SASL (unknown error)
> 2015-01-21 17:10:02,119 WARN org.apache.zookeeper.ClientCnxn: Session 0x0
> for server null, unexpected error, closing socket connection and attempting
> reconnect
> java.net.ConnectException: Connection refused
>         at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>         at
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:735)
>         at
>
> org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
>         at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1075)
>
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067775.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Shaun Elliott
In reply to this post by Ted Yu-3

Yes, I believe so.

On January 21, 2015 5:40:26 PM "Ted Yu-3 [via Apache HBase]" <[hidden email]> wrote:

The znode listed below is hbaseid.

Is that correct ?

Cheers



> On Jan 21, 2015, at 5:32 PM, Shaun Elliott <[hidden email]> wrote:
>
> We're trying to use the built in table copy command to copy from one cluster
> to another:
>
> hbase org.apache.hadoop.hbase.mapreduce.CopyTable
> --peer.adr=host1,host2,host3:2181:/hbase TableName
>
> But we're getting the following error:
> 2015-01-21 17:10:01,017 ERROR
> org.apache.hadoop.hbase.zookeeper.ZooKeeperWatcher: hconnection Received
> unexpected KeeperException, re-throwing exception
> org.apache.zookeeper.KeeperException$ConnectionLossException:
> KeeperErrorCode = ConnectionLoss for /hbase/hbaseid
>    at org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
>    at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
>    at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:1041)
>    at
> org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.exists(RecoverableZooKeeper.java:172)
>    at org.apache.hadoop.hbase.zookeeper.ZKUtil.checkExists(ZKUtil.java:450)
>    at
> org.apache.hadoop.hbase.zookeeper.ClusterId.readClusterIdZNode(ClusterId.java:61)
>    at org.apache.hadoop.hbase.zookeeper.ClusterId.getId(ClusterId.java:50)
>    at org.apache.hadoop.hbase.zookeeper.ClusterId.hasId(ClusterId.java:44)
>
> Zookeeper and HBase are running fine on both clusters. Is there something
> else missing here?
>
>
>
> --
> View this message in context: http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774.html
> Sent from the HBase User mailing list archive at Nabble.com.



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067776.html
To unsubscribe from zookeeper connection loss on table copy, click here.
NAML
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Shaun Elliott
In reply to this post by stack-3

Yes, it is.

On January 21, 2015 5:40:56 PM "stack-3 [via Apache HBase]" <[hidden email]> wrote:

zk is listening on port 2181?
St.Ack

On Wed, Jan 21, 2015 at 5:33 PM, Shaun Elliott <[hidden email]>
wrote:

> It is also throwing this:
>
> 2015-01-21 17:10:02,118 INFO org.apache.zookeeper.ClientCnxn: Opening
> socket
> connection to server localhost.localdomain/127.0.0.1:2181. Will not
> attempt
> to authenticate using SASL (unknown error)
> 2015-01-21 17:10:02,119 WARN org.apache.zookeeper.ClientCnxn: Session 0x0
> for server null, unexpected error, closing socket connection and attempting
> reconnect
> java.net.ConnectException: Connection refused
>         at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>         at
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:735)
>         at
>
> org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
>         at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1075)
>
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067775.html
> Sent from the HBase User mailing list archive at Nabble.com.
>



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067777.html
To unsubscribe from zookeeper connection loss on table copy, click here.
NAML
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

stack-3
On Wed, Jan 21, 2015 at 5:45 PM, Shaun Elliott <[hidden email]>
wrote:

> Yes, it is.
>
>
Says "java.net.ConnectException: Connection refused" It is trying to
connect on wrong port or address.
St.Ack




>
> On January 21, 2015 5:40:56 PM "stack-3 [via Apache HBase]"
> <[hidden email]> wrote:
>
> >
> >
> > zk is listening on port 2181?
> > St.Ack
> >
> > On Wed, Jan 21, 2015 at 5:33 PM, Shaun Elliott <[hidden email]>
> > wrote:
> >
> > > It is also throwing this:
> > >
> > > 2015-01-21 17:10:02,118 INFO org.apache.zookeeper.ClientCnxn: Opening
> > > socket
> > > connection to server localhost.localdomain/127.0.0.1:2181. Will not
> > > attempt
> > > to authenticate using SASL (unknown error)
> > > 2015-01-21 17:10:02,119 WARN org.apache.zookeeper.ClientCnxn: Session
> 0x0
> > > for server null, unexpected error, closing socket connection and
> attempting
> > > reconnect
> > > java.net.ConnectException: Connection refused
> > >         at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
> > >         at
> > > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:735)
> > >         at
> > >
> > >
> >
> org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
> > >         at
> > > org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1075)
> > >
> > >
> > >
> > >
> > > --
> > > View this message in context:
> > >
> >
> http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067775.html
> > > Sent from the HBase User mailing list archive at Nabble.com.
> > >
> >
> >
> >
> >
> > _______________________________________________
> > If you reply to this email, your message will be added to the discussion
> below:
> >
> http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067777.html
> >
> > To unsubscribe from zookeeper connection loss on table copy, visit
> >
>
>
>
>
> --
> View this message in context:
>
http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067779.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Shaun Elliott
I'm not sure why it is trying to connect to ZK on localhost, maybe that is the default? I added this property to the job to get it to work:

-Dhbase.zookeep.quorum=host1,host2,host3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Ted Yu-3
Here is the help message for peer.adr parameter:

peer.adr     Address of the peer cluster given in the format

hbase.zookeeer.quorum:hbase.zookeeper.client.port:zookeeper.znode.parent

Looks like the parameter in your initial command didn't conform to the
above format.

On Thu, Jan 22, 2015 at 9:38 AM, Shaun Elliott <[hidden email]>
wrote:

> I'm not sure why it is trying to connect to ZK on localhost, maybe that is
> the default? I added this property to the job to get it to work:
>
> -Dhbase.zookeep.quorum=host1,host2,host3
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067794.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Shaun Elliott

The peer address property was not a problem.

On January 22, 2015 9:50:44 AM "Ted Yu-3 [via Apache HBase]" <[hidden email]> wrote:

Here is the help message for peer.adr parameter:

peer.adr     Address of the peer cluster given in the format

hbase.zookeeer.quorum:hbase.zookeeper.client.port:zookeeper.znode.parent

Looks like the parameter in your initial command didn't conform to the
above format.

On Thu, Jan 22, 2015 at 9:38 AM, Shaun Elliott <[hidden email]>
wrote:

> I'm not sure why it is trying to connect to ZK on localhost, maybe that is
> the default? I added this property to the job to get it to work:
>
> -Dhbase.zookeep.quorum=host1,host2,host3
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067794.html
> Sent from the HBase User mailing list archive at Nabble.com.
>



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4067795.html
To unsubscribe from zookeeper connection loss on table copy, click here.
NAML
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

xiangyu
Hi, I got the same message like connect to server localhost zookeeper when I use CopyTable. Have you solved this problem?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Shaun Elliott
Yes, I solved it by adding this:

-Dhbase.zookeep.quorum=host1,host2,host3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: zookeeper connection loss on table copy

Ted Yu-3
Maybe it was a typo. I guess you meant:

-Dhbase.zookeeper.quorum=...

On Wed, May 31, 2017 at 8:31 AM, Shaun Elliott <[hidden email]>
wrote:

> Yes, I solved it by adding this:
>
> -Dhbase.zookeep.quorum=host1,host2,host3
>
>
>
> --
> View this message in context: http://apache-hbase.679495.n3.
> nabble.com/zookeeper-connection-loss-on-table-copy-tp4067774p4088251.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
Loading...