Quantcast

standalone HBase instance fails to start

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

standalone HBase instance fails to start

matan
Hi,

My standalone HBase instance, installed as per the 'getting started' section at  http://hbase.apache.org/book/quickstart.html, doesn't work insofar.

I get in the log file:

2012-11-23 18:26:37,827 INFO org.apache.zookeeper.ClientCnxn: Session establishment complete on server localhost/127.0.0.1:2181, sessionid = 0x1
3b2e17842c0002, negotiated timeout = 40000
2012-11-23 18:26:37,866 INFO org.apache.hadoop.ipc.HBaseRPC: Server at localhost/127.0.0.1:39699 could not be reached after 1 tries, giving up.
2012-11-23 18:26:37,867 WARN org.apache.hadoop.hbase.master.AssignmentManager: Failed assignment of -ROOT-,,0.70236052 to localhost,39699,135368
7992912, trying to assign elsewhere instead; retry=0
org.apache.hadoop.hbase.client.RetriesExhaustedException: Failed setting up proxy interface org.apache.hadoop.hbase.ipc.HRegionInterface to loca
lhost/127.0.0.1:39699 after attempts=1
.
.
.
2012-11-23 18:26:37,869 WARN org.apache.hadoop.hbase.master.AssignmentManager: Unable to find a viable location to assign region -ROOT-,,0.70236
052
2012-11-23 18:29:53,157 ERROR org.apache.hadoop.hbase.master.HMasterCommandLine: Failed to start masterv

This is on an Ubuntu 12.04 LTS VirtualBox, 1GB Memory, 10GB free disk space, with Oracle JRE 1.6.0_37.

I found some workarounds talking about /etc/hosts but am not sure whether they are relevant. My etc/hosts contains only:

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

I'm really stuck here.
Any help would be very much appreciated! Thanks!
I also posted this at stackoverflow before finding this mailing list (... promise to update both when I have it resolved)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

ramkrishna vasudevan
Just try adding this entry alone in your local host

127.0.0.1  'hostname'

and then try.. Recently i faced this problem and it got resolved.

Regards
Ram

On Sat, Nov 24, 2012 at 2:16 PM, matan <[hidden email]> wrote:

> Hi,
>
> My standalone HBase instance, installed as per the 'getting started'
> section
> at  http://hbase.apache.org/book/quickstart.html, doesn't work insofar.
>
> I get in the log file:
>
> 2012-11-23 18:26:37,827 INFO org.apache.zookeeper.ClientCnxn: Session
> establishment complete on server localhost/127.0.0.1:2181, sessionid = 0x1
> 3b2e17842c0002, negotiated timeout = 40000
> 2012-11-23 18:26:37,866 INFO org.apache.hadoop.ipc.HBaseRPC: Server at
> localhost/127.0.0.1:39699 could not be reached after 1 tries, giving up.
> 2012-11-23 18:26:37,867 WARN
> org.apache.hadoop.hbase.master.AssignmentManager: Failed assignment of
> -ROOT-,,0.70236052 to localhost,39699,135368
> 7992912, trying to assign elsewhere instead; retry=0
> org.apache.hadoop.hbase.client.RetriesExhaustedException: Failed setting up
> proxy interface org.apache.hadoop.hbase.ipc.HRegionInterface to loca
> lhost/127.0.0.1:39699 after attempts=1
> .
> .
> .
> 2012-11-23 18:26:37,869 WARN
> org.apache.hadoop.hbase.master.AssignmentManager: Unable to find a viable
> location to assign region -ROOT-,,0.70236
> 052
> 2012-11-23 18:29:53,157 ERROR
> org.apache.hadoop.hbase.master.HMasterCommandLine: Failed to start masterv
>
> This is on an Ubuntu 12.04 LTS VirtualBox, 1GB Memory, 10GB free disk
> space,
> with Oracle JRE 1.6.0_37.
>
> I found some workarounds talking about /etc/hosts but am not sure whether
> they are relevant. My etc/hosts contains only:
>
> ::1     ip6-localhost ip6-loopback
> fe00::0 ip6-localnet
> ff00::0 ip6-mcastprefix
> ff02::1 ip6-allnodes
> ff02::2 ip6-allrouters
>
> I'm really stuck here.
> Any help would be very much appreciated! Thanks!
> I also posted this at  stackoverflow
> <http://stackoverflow.com/questions/13533283/hbase-fails-to-start>
> before
> finding this mailing list (... promise to update both when I have it
> resolved)
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

matan
Thanks! seems to be working!

On Sat, Nov 24, 2012 at 1:11 PM, ramkrishna vasudevan [via Apache HBase] <[hidden email]> wrote:
127.0.0.1  'hostname'

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

Jean-Marc Spaggiari
Maybe this should be added in the documentation as an hint?
Le 24 nov. 2012 06:24, "matan" <[hidden email]> a écrit :

> Thanks! seems to be working!
>
> On Sat, Nov 24, 2012 at 1:11 PM, ramkrishna vasudevan [via Apache HBase] <
> [hidden email]> wrote:
>
> > 127.0.0.1  'hostname'
>
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034335.html
> Sent from the HBase User mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

matan
As for myself, I'm not 100% sure why it is necessary to change this IP address from one loopback address to the other, so I cannot fully suggest a change in that respect myself.. anyway, it may seem that change is only necessary in Ubuntu/Debian, if that matters in terms of how many people need to make that change.


On Sat, Nov 24, 2012 at 2:41 PM, Jean-Marc Spaggiari [via Apache HBase] <[hidden email]> wrote:
Maybe this should be added in the documentation as an hint?
Le 24 nov. 2012 06:24, "matan" <[hidden email]> a écrit :

> Thanks! seems to be working!
>
> On Sat, Nov 24, 2012 at 1:11 PM, ramkrishna vasudevan [via Apache HBase] <
> [hidden email]> wrote:
>
> > 127.0.0.1  'hostname'
>
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034335.html

> Sent from the HBase User mailing list archive at Nabble.com.



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034336.html
To unsubscribe from standalone HBase instance fails to start, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

matan
In reply to this post by Jean-Marc Spaggiari
It's included here http://hbase.apache.org/book.html actually, maybe link the 'getting started' page to that page, unless it's becoming unfavorably cyclic.


On Sat, Nov 24, 2012 at 6:40 PM, Matan Safriel <[hidden email]> wrote:
As for myself, I'm not 100% sure why it is necessary to change this IP address from one loopback address to the other, so I cannot fully suggest a change in that respect myself.. anyway, it may seem that change is only necessary in Ubuntu/Debian, if that matters in terms of how many people need to make that change.


On Sat, Nov 24, 2012 at 2:41 PM, Jean-Marc Spaggiari [via Apache HBase] <[hidden email]> wrote:
Maybe this should be added in the documentation as an hint?
Le 24 nov. 2012 06:24, "matan" <[hidden email]> a écrit :

> Thanks! seems to be working!
>
> On Sat, Nov 24, 2012 at 1:11 PM, ramkrishna vasudevan [via Apache HBase] <
> [hidden email]> wrote:
>
> > 127.0.0.1  'hostname'
>
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034335.html

> Sent from the HBase User mailing list archive at Nabble.com.



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034336.html
To unsubscribe from standalone HBase instance fails to start, click here.
NAML


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

stack-3
In reply to this post by Jean-Marc Spaggiari
On Sat, Nov 24, 2012 at 4:40 AM, Jean-Marc Spaggiari
<[hidden email]> wrote:
> Maybe this should be added in the documentation as an hint?

We have a section on loopback here:
http://hbase.apache.org/book.html#basic.prerequisites

What should we add to it?

St.Ack
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

stack-3
In reply to this post by matan
On Sat, Nov 24, 2012 at 9:45 AM, matan <[hidden email]> wrote:
> It's included here http://hbase.apache.org/book.html actually, maybe link
> the 'getting started' page to that page, unless it's becoming unfavorably
> cyclic.
>

I did as you suggested by listing java, loopback and ssh as prereqs
for getting started.
St.Ack
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

matan
In reply to this post by stack-3
Nothing. Maybe just link to it from http://hbase.apache.org/book/quickstart.html such that people for whom the quick start doesn't work, will have a direct route to this and other prerequisites.


On Sun, Nov 25, 2012 at 5:53 AM, stack-3 [via Apache HBase] <[hidden email]> wrote:
On Sat, Nov 24, 2012 at 4:40 AM, Jean-Marc Spaggiari
<[hidden email]> wrote:
> Maybe this should be added in the documentation as an hint?

We have a section on loopback here:
http://hbase.apache.org/book.html#basic.prerequisites

What should we add to it?

St.Ack



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034347.html
To unsubscribe from standalone HBase instance fails to start, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

stack-3
On Sun, Nov 25, 2012 at 8:28 AM, matan <[hidden email]> wrote:
> Nothing. Maybe just link to it from
> http://hbase.apache.org/book/quickstart.html such that people for whom the
> quick start doesn't work, will have a direct route to this and other
> prerequisites.
>

I just added note on loopback to the getting started:
http://hbase.apache.org/book.html#quickstart

I don't want to clutter the getting started w/ a long list of prereqs
that actually are not needed putting up hbase in standalone mode; e.g.
you don't need to make sure ssh to localhost is working when doing
standalone.

Thanks.  Any other suggestions on how to improve the doc. are most welcome.
St.Ack
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: standalone HBase instance fails to start

matan
Thanks again, seems helpful for (Ubuntu) quick starting.


On Mon, Nov 26, 2012 at 7:44 PM, stack-3 [via Apache HBase] <[hidden email]> wrote:
On Sun, Nov 25, 2012 at 8:28 AM, matan <[hidden email]> wrote:
> Nothing. Maybe just link to it from
> http://hbase.apache.org/book/quickstart.html such that people for whom the
> quick start doesn't work, will have a direct route to this and other
> prerequisites.
>

I just added note on loopback to the getting started:
http://hbase.apache.org/book.html#quickstart

I don't want to clutter the getting started w/ a long list of prereqs
that actually are not needed putting up hbase in standalone mode; e.g.
you don't need to make sure ssh to localhost is working when doing
standalone.

Thanks.  Any other suggestions on how to improve the doc. are most welcome.
St.Ack



If you reply to this email, your message will be added to the discussion below:
http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333p4034405.html
To unsubscribe from standalone HBase instance fails to start, click here.
NAML

Loading...